SOLVED Cant hit target Boost, have tried everything!

Apr 22, 2019
10
Hi Everyone,


Id really appreciate some insight if anyone has any as im straight out of ideas and becoming frustrated with this platform. Ive been trying to find out why i cant seem to hit target boost for what seems like the longest time. Here is a quick run down on my mods and what has been done to try and fix the issue.

Pure stage 1 (brand new)
Relocated Inlets
7" HD VRSF Intercooler
Chargepipe
MOTIV Custom Tune 91 octane
Turbosmart BPV's

Some maintenance items and fail safes i just recently completed.

Brand new Solenoids
Brand new vac lines
Ensured waste gates arnt touching the ******** v band
Just last night took all my cold side piping apart and put it all back tight as can be.

After all this, i still cant hit my targets, here are a couple data logs. if anyone has any insight i would much appreciate it, or what i should do to try and solve this problem.

thanks in advance

https://datazap.me/u/stealthbombing/...og=0&data=3-21
https://datazap.me/u/stealthbombing/...og=0&data=3-21

Here is a 5th gear mini pull, for some reason half throttle i come closer to my targets and my WGDC isnt maxed

https://datazap.me/u/stealthbombing/...og=0&data=3-21
 

tisdrew

Corporal
Jun 27, 2017
100
New vacuum lines, maybe one popped off. Check them and maybe smoke-test it.

Also your links don't work.
 
Apr 22, 2019
10
How would that affect my WGDC ? to me it looks like WGDC is maxing out but Boost isnt adjusting. Or is it because my fuel trims are maxing out due to the fuel pump that its not making more boost, in that case wouldnt less vacuum be applied to the Waste gates
 
Apr 22, 2019
10
I found my leak, its leaking at the throttle body from the charge pipe. I have the Phoenix Racing CP from BMS and i found that if i move it around slightly while everything is pressurized it looses its seal. Do the o rings go bad?
 

Torgus

Captain
Nov 6, 2016
1,045
Boston
I found my leak, its leaking at the throttle body from the charge pipe. I have the Phoenix Racing CP from BMS and i found that if i move it around slightly while everything is pressurized it looses its seal. Do the o rings go bad?
I would just contact BMS. They have amazing customer service. I am sure they will sort it out for you.

Rubber tends to eventually dry out and become brittle over time. I highly doubt that is your problem.
 
Top