N54 Configuring Syvecs for Speed-Density Fueling

Feb 11, 2018
15
#1
I ordered a Syvecs for my 335i a few weeks ago and I'm still waiting for it to arrive. Meanwhile, I've been talking with Rac from Australia about some of the issues involved with the base map that Syvecs provided him. He was kind enough to share his base map with me, since I haven't bothered to contact Syvecs Support yet.

First off, the Syvecs base map's Run-Mode Fuelling is set up for a 4-dimensional model that uses tables for both manifold pressure and throttle position, and there is a separate table used to blend these two curves together. Presumably, this was done so that the ECU was truly plug-and-play, requiring no mechanical modification to work. The base map had no values in the MAP table and only the TPS table was populated. I don't plan to use this setup, as I'm opting to move the boost pressure sensor from the chargepipe to the manifold plenum so I can run a traditional 3-D speed density model.

Since there are no values populated in the Base Injection Time tables, you would be starting from scratch unless you copy the TPS fuel table values to the MAP table after taking into account some known data points correlating throttle position to MAP values. For example: your throttle position at idle and corresponding MAP, or throttle position at 14.7psia (atmospheric) could be used to generate a rudimentary fuel table for a few different engine speeds. The Secondary Load Injection Time Blend table would also need to be zero'd out, as it was populated with 100% in the entire table for using throttle position as the only load input.

Rac said this worked ok to get the car up and running using MAP only. All he had to do was swap sensor locations. Has anyone tried a similar strategy to get the engine running using MAP only? If so, how did it work? Did you do something else entirely?
 
Nov 8, 2017
39
Seattle
#3
I downloaded "Sensor Database 2018" which contains a bunch text files. These files appear to contain data packaged in a "C"-type of language. This makes sense, considering Syvecs is programmed for Windows. Welp, that covers SCal. If the rest of the SSuite packages export the same or CAN protocol that would be awesome. For anyone who's interested, here's the manual: http://www.syvecs.com/downloads/Syvecs Manual V1.1.pdf
 
Feb 11, 2018
15
#4
What is the format of the data points? For example if I want to export a data set from Syvecs to use for analysis or modeling elsewhere. It seems that Syvecs software is Windows only, but I'm hoping the raw data is portable…
If you're talking about the fueling values (which are in milliseconds), ignition values, etc. in SCal, the entire table can be copied and pasted into Excel or notepad. However, breakpoints cannot be copied along with the data and will have to be entered manually to corresponding rows and columns. I don't think you'll be able to easily paste an entire table into SCal, though. I have not found a way to export a table directly, only copy/paste works.

Since I don't have my ECU yet, I haven't tried using SMon to export data from a log, and I don't know what formats are available for export.
 

AD-ENG

Corporal
Free Vendor
Oct 22, 2016
116
#5
I run the syvecs in speed density.

Base injection will be your main fuel table and zero out the "secondary load injection time blend" table. This will use 100% of the base injection table (rpm,map1).

You will need to install a map sensor in the intake manifold. You can NOT use the 3.5bar tmap for a speed density map sensor. However, you can leave it in the chargepipe and use the IAT that's in it.
 

rac

Private
Nov 14, 2016
49
Australia
#8
Doesn't read enough vacuum.
That is interesting. I was reading about 6.83psi (absolute) minimum while testing on idle I was expecting a little less based on past experience but I wasn't 100% sure if my old lower readings were from coasting or from idle. Now that you mention this going back to my log it looks like it definitely flatlined there, might explain a few headaches I was having. What sensor are you using?

Also are you using LSU 4.9 for a wideband on firmware 1.87?
 

AD-ENG

Corporal
Free Vendor
Oct 22, 2016
116
#10
That is interesting. I was reading about 6.83psi (absolute) minimum while testing on idle I was expecting a little less based on past experience but I wasn't 100% sure if my old lower readings were from coasting or from idle. Now that you mention this going back to my log it looks like it definitely flatlined there, might explain a few headaches I was having. What sensor are you using?

Also are you using LSU 4.9 for a wideband on firmware 1.87?
Correct. Manifold vacuum at idle and low tip-in is below where the 3.5bar tmap flatlines. You'll find yourself chasing your tail trying to dial idle fuel in.

Any traditional absolute map sensor will work. I make a pnp adapter harness with an AEM 5BAR sensor.
s947106067457903682_p42_i1_w640.jpeg


I use ntk wideband sensors.
 
Nov 8, 2017
39
Seattle
#11
Any traditional absolute map sensor will work. I make a pnp adapter harness with an AEM 5BAR sensor.
I was wondering why you offered a pnp 5BAR… I read elsewhere on the forums speculations about how to utilize it… #SYVECS
 

rac

Private
Nov 14, 2016
49
Australia
#13
Correct. Manifold vacuum at idle and low tip-in is below where the 3.5bar tmap flatlines. You'll find yourself chasing your tail trying to dial idle fuel in.

Any traditional absolute map sensor will work. I make a pnp adapter harness with an AEM 5BAR sensor.
View attachment 15540

I use ntk wideband sensors.
yeah, I went mad going ultra lean to ultra rich and decided my wideband was faulty. probably is now....

i'd prefer to use ntk but my understanding is to switch to ntk some solder bridges need to be changed on the ecu board itself from how the pnp kit comes shipped, its detailed in the generic S6 manual, is that correct?
 

AD-ENG

Corporal
Free Vendor
Oct 22, 2016
116
#14
yeah, I went mad going ultra lean to ultra rich and decided my wideband was faulty. probably is now....

i'd prefer to use ntk but my understanding is to switch to ntk some solder bridges need to be changed on the ecu board itself from how the pnp kit comes shipped, its detailed in the generic S6 manual, is that correct?
The ntk sensors I use do not require any changes to the board... they are pnp. They are also pnp replacements for the stock Bosch sensors on the factory dme.
 

rac

Private
Nov 14, 2016
49
Australia
#15
The ntk sensors I use do not require any changes to the board... they are pnp. They are also pnp replacements for the stock Bosch sensors on the factory dme.
Just change the linearization curve to L2H2 and tweak on the dyno against a known wideband?
My current SCal has LSU feedback and heater outputs specific to LSU widebands, do reconfigure this for the NTK? The LSU sensors being so sensitive to the heating strategy I didn't think it could be literally pnp.
 

AD-ENG

Corporal
Free Vendor
Oct 22, 2016
116
#16
Just change the linearization curve to L2H2 and tweak on the dyno against a known wideband?
My current SCal has LSU feedback and heater outputs specific to LSU widebands, do reconfigure this for the NTK? The LSU sensors being so sensitive to the heating strategy I didn't think it could be literally pnp.
As stated above, this a Bosch replacement sensor by NTK. It is a pnp replacement to the n54, regardless of being on a syvecs or stock dme. Been running this sensor in every n54 here for 4+ years now.
 

rac

Private
Nov 14, 2016
49
Australia
#18
Why won't a 3.5 bar tmap work, such as the Continental 13627843531 used in the N20?
Thought I'd update this topic, been travelling and working away from the car... The stock 2.5 bar sensor works for me as it goes down to 0.2 bar minimum as does a Bosch TMAP I found with 0.2 to 3 bar range. So basically you need to get down to 0.2 bar as opposed the 0.5 bar minimum on the N20.
 

Similar threads

Top