Delete

doublespaces

Administrator
Oct 18, 2016
7,236
AZ
Good theory, all makes sense. I got a buddy going over to check later. Hopefully belt broke and it got sucked into front main seal, so I can finally walk away from that car. It’s cursed. For real.
Maybe the axle got stuck in the transfer case again.
 
  • Dumb
Reactions: fredcase

Seaneezy

Specialist
Mar 12, 2018
73
seems like something IBS (intelligent battery sensor) would throw at you. I was specifically having that steering angle code before I got a new coded battery that fixed it.
 
  • Like
Reactions: fredcase

Rcboosted2007

Lieutenant
Jan 28, 2018
875
Parts unknown
Just a guess, but did you check your fuse for the coolant pump. Its a large 40-50amp. Also check the “ fuses” on top of your battery. The red cable/box attachment is actually a set of blade fuses
 
  • Like
Reactions: fredcase

Rob09msport

Captain
Oct 28, 2017
1,178
Monroe CT
Their was a recall regarding the cable that runs behind dash and glove box. I believe it Is all lhd so yes Canada should have the issue. What MY and chassis is your car I'll see if I can get info if campaign covers you in Canada
 

Rob09msport

Captain
Oct 28, 2017
1,178
Monroe CT
People were having their cars burn down cause of the short from battery cable recall I was referencing. Reading high voltage is confusing though. That was an internal reading from cars sensor or a voltmeter connected to car?
 
  • Like
Reactions: fredcase

Tiron

New Member
Oct 10, 2018
7
A while ago I had the voltage regulator go bad in my 2007 335i, dashboard lit up like a Christmas tree. Trans light and everything. When the voltage goes over about 16v, the water pump shuts off (and I'm sure other things as well). Get a multimeter and make sure your voltage is in spec.
 

JimboFresh206

Corporal
Jan 29, 2018
177
Can confirm on the voltage regulator whackyness, mine had the added benefit of acutally igniting the blower motor wiring when it went (along with the super awesome shut down the water pump on the express lanes and every light possible) lol

Replaced the reg and voltage went back to.normal instead of the 16-19v it was trying to put out.

Dead alts usually whine, squeak, and have low output.


27684
 
  • Like
Reactions: fredcase
Top