E9X Failing Waterpump

Discussion in 'N55' started by 335iHaroon, Nov 5, 2016.

Trader History (0)
  1. 335iHaroon

    335iHaroon Specialist

    Anyone know the signs that your waterpump is starting to fail?

    My radiator fan has been blowing really hard randomly and the car drives like crap for lack of better word.
     
  2. doublespaces

    doublespaces Administrator

    AZ
    2009 E93 335i
    Has it thrown any codes?
     
  3. 335iHaroon

    335iHaroon Specialist

    Haven't scanned it yet but used jb4 and got these
     

    Attached Files:

  4. doublespaces

    doublespaces Administrator

    AZ
    2009 E93 335i
    Just now, or you saw that before posting here? I don't have any experience trouble shooting the N55, so I can't give you much advice here.
     
  5. 335iHaroon

    335iHaroon Specialist

    This started a few days ago I believe they're still there though
     
  6. doublespaces

    doublespaces Administrator

    AZ
    2009 E93 335i
    Ah, yeah well you gotta be careful with coolant temps. With these cars its more than just messing up your thermostat, as you probably know.
     
  7. 335iHaroon

    335iHaroon Specialist

    Yeah man need to replace it asap. Thermostat probably about to go as well :/.
     
  8. 377a Water Pump Blocked: that's how it started with mine, as well. Replacement needed urgently. Normally you should also get an engine light and with higher temps also a massive loss of power with max 60kph. Not a cheap fix, if you have to pay the dealer. The (electric!) pump is also not cheap.

    When changing check the thermostat and reservoir (the black bucket on the left side of the engine bay). The reservoir is known to break/ leak, especially with higher pressures after the pump blocked.

    I would change both nonetheless.
     
  9. 335iHaroon

    335iHaroon Specialist


    I'm planning on doing it my self seems pretty straight forward changing the thermostat as well parts I found for a total of $550 oem parts. Car is driving really weird and lackluster but temps seem to be normal. Can't see the check engine cause of the jb4 though
     
  10. How prone to failure are these pumps? do they all eventually fail and need replacement or only some?
     
  11. I know no other N54/N55 owner to not have replaced the WP. Normally they last until somewhere around 100kkm. Mine lasted until 95kkm and went bust in the Italien Dolomites (ruined the weekend, as the failure popped up on Friday late afternoon :( )
     
  12. doublespaces

    doublespaces Administrator

    AZ
    2009 E93 335i
    At least they are electric and won't jack up your engine by seizing up etc. Though, they are plastic impellers also.
     
  13. 335iHaroon

    335iHaroon Specialist

    They tend to go at 70k miles usually
     
  14. Is this just an E series N55 problem or have there been F series with this problem as well?
     
  15. 335iHaroon

    335iHaroon Specialist

    Haven't heard of many f30s having this issue so I suppose not
     
  16. Zebaztian7

    Zebaztian7 Lurker

    18
    West Texas
    2011 E92 335i xDrive
    Mine went out at the 80k mark.
     

Share This Page