Grey Smoke at startup

rami.ad

Lurker
Aug 28, 2017
13
Maybe Im not the luckiest N54 owner been having a new issue each month.
Couple of days ago i noticed some smoke behind the car when i was going a downhill like 2 min after i warmed up my car and drove. This happened today as well Im not sure what is the problem.
The car doesnt smoke at startup at all
Not even black rich (new injectors idex 12 instaled like a month ago).
It smokes only after i drive like 2-3 minutes and i go downhill (not pushing gas)
As soon as i step my foot on the gas pedal the grey smoke disapears and i continue driving normally.
No codes nothing feeling wrong just a slow grey cloud behind after i run the car in the morning.
Note that i have gutted (emptied) oem downpipes (living in Lebanon no after market parts)
Im on MHD stage 2.
Couple of months ago I had some grey smoke i sent the car to a local shop they changed the valve stem seals (Im doubting their work now, might be the case?). After this fix i purchased RB PVC valve and when instaling the pcv, the duct going from valve to intake was cut so i asked the idiot to ditch the line into a cheap occ can and vent to the atmosphere.
Anyone had similar symptoms?
What im thinking now is puting back the stock pcv valve since its ditched out to the air anyways maybe the RB PCV is causing a high block pressure and oil is seeping beyond the pistong rings.
The car is 335i 2009 and the turbos seem fine no rattle nothing and boosting 18 psi
 

Similar threads


Top