How to flash the BMW DCT

doublespaces

Administrator
Oct 18, 2016
7,329
AZ
What was the big deal about the EDC suspension anyway, I heard people were ripping them out, is it any better than our sport suspension? I think their suspension is different than ours so it wouldn't transfer over would it?
 

Mohd-335

New Member
Jun 4, 2018
4
Thank you sir for the efforts.

I have 2009 335i e92 N54 with DCT, which ZB do you advise me to go with based on your experience? And is it Manditory to rest the adaption? If yes, how to do the adaption?
 

aus335iguy

Lieutenant
Nov 18, 2017
931
Thank you sir for the efforts.

I have 2009 335i e92 N54 with DCT, which ZB do you advise me to go with based on your experience? And is it Manditory to rest the adaption? If yes, how to do the adaption?
Mostly people like us flash the 135is file for 3500rpm launch control. The current thinking remains that adaptions don’t need to be reset as far as we can tell the relearn can prematurely wear the clutches and isn’t really needed.
 

Mohd-335

New Member
Jun 4, 2018
4
Mostly people like us flash the 135is file for 3500rpm launch control. The current thinking remains that adaptions don’t need to be reset as far as we can tell the relearn can prematurely wear the clutches and isn’t really needed.
How long does it tack to relearn, is there specific kilometers?

thank you for your support
 

Mohd-335

New Member
Jun 4, 2018
4
Hi Gentlemen

I flashed the 135is succesfuly, no codes and everything working perfect except LC

I’m tying but the car won’t go more then 2000 rpm ang goes again to 600rpm same as stock

Any suggestions please
 

aus335iguy

Lieutenant
Nov 18, 2017
931
Does your car have any codes that haven’t been reset? Is the car up to temp?
Do you have kick down disabled? Are you pressing your foot down past the kickdown(past the click in the pedal near the end of its travel)?
What procedure are you following to launch ?
 
Last edited:

Mohd-335

New Member
Jun 4, 2018
4
Does your car have any codes that haven’t been reset?
Do you have kick down disabled? What procedure are you following to launch ?
No codes other than the brack sensor only need to be change (service), the kickdown activated.
I turn off the DTC, push the sport button, gear on M1, brick and full gas
 
Last edited:
  • Like
Reactions: doublespaces

ganque

Private
Jan 22, 2018
42
I'm having some issues trying to install the most recent ZSUB file on my car with WinKFP.
I get the following errors:

Code: 1065 Error - Procedure: CDHIntSetScriptFile - Coding Sequence description file (CABD) 00GS40.IPO not found or erroneous

Attached is the screenshot. Any inputs? I installed the proper IPO file in the SGDAT folder.
 

Attachments

chrislconner

New Member
Mar 13, 2019
1
Tennessee
This is a great tutorial but I am having a slight issue. I can code with NCS Expert no problem, use INPA, and Tool32. WinKFP loads up fine with no errors but when attempting to select GS40 for my ECU family, it is not there. There are several other ECU families but anything related to the TCU isn't showing up. I have updated to daten 60.1 from bimmergeeks download and used BMW coding tool to update the daten files so I can't mess it up. I checked my HWNR.DA2 file in my gdaten folder for zusb 8606074 (which is what my 335is shows in INPA under UIF) and also 8606072 (which is what I want for 3500 rpm lc) and the only thing that comes up is 8606066 under column $SG GS40. Regardless of the zb number wanted not present, GS40 is showing up. How do I get GS40 to populate in ECU families? I feel like I am lacking a small detail or the daten files may be too new? I don't see that being the case though.
 

RSL

Sergeant
Aug 11, 2017
356
SG = control module and IIRC, 8606066 is the PN number of the TCU, it's not a ZB number. It should be the right module (TCU), but you can verify in INPA (EGS/DKG).

Are you using comfort mode in WinKFP? Unless something has changed in newer builds, should just have to select Choose ZB->GS40->select ZB->Program/Execute. Been a long while since I flashed anything, so I may just not be remembering correctly.

Maybe take a screen of what you're seeing and/or step-by-step of how you're getting there.
 

aus335iguy

Lieutenant
Nov 18, 2017
931
I had some issues flashing initially but don’t recall that sorry. As RSL said post up a screen shot perhaps?
 
Top