jb4 2step doesnt hold set rpm

Discussion in 'N54' started by AK135i, Mar 9, 2017.

Trader History (0)
  1. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    First post, and a noob here, so I apologize in advance if this has already been discussed I searched and couldn't find any threads that covered this problem with a solution. So the issue is ever since ive installed the 2step relay with jb4 (with current firmware) the car will randomly 2step past the set limiter, its more accurate at higher rpm settings, and very rarely will it hold at the set rpm value. It seems like this is a common problem, any help is appreciated. If this is just the nature of the beast, then I will be considering removing it and go WOTbox. I bought the jb4 relay originally for the NLS feature, but it has piss poor performance, I can shift faster lifting off the throttle then NLSing, the throttle is too slow to reach 100% again compared to letting off slightly and mashing it again. Thanks for the help. o_O
     
  2. V8bait

    V8bait Corporal

    Jb4 NLS was always slower than my shifts, I think it just senses the clutch pedal. WOTbox is adjustable so you can set a shift time, it's much better although if you take too much longer than the set shift time you can rev too high and trigger bog. It feels much better when you nail the shifts though.
     
  3. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    Out of curiosity does the WOT box also have a 2step feature, or is it strictly for NLSing. Im considering a drag set up where 2step would actually be practical.
     
  4. Icewall

    Icewall Lurker

    15
    NJ
    yes the 2step doesnt work correctly. thats a known issue.

    Also it has been said in the past that wotbox 2step has made the crank bolt walk out. I believe thats why you don't see too many people using the wotbox.
     
  5. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    good to know.... ill just stick with NLS I don't need scene points
     
  6. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    It makes no sense to advertise and sell a product that doesn't work properly.
     
  7. Terry@BMS

    [email protected] Corporal Vendor

    145
    The NLS works awesome, must have for any manual racing. Post a log using NLS and not using it and we'll see why the NLS is not working better for you. On our development cars it's night and day better.

    The 2STEP works but the RPM targeting is not always perfect. A lot of little factors like flywheel weight, fuel used, etc, effect it and we've not perfected the PID control on it. But it's something we're always screwing with.
     
  8. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    I can take another log and post it up, but from my logs in the past they've always looked great, and don't get me wrong, the NLS feature does work, its just very delayed and its almost as if im waiting a full second or two for the throttle to come back 100%
     
  9. V8bait

    V8bait Corporal

    I only used it for NLS. Jb4 sounds better if you need 2step
     
  10. Terry@BMS

    [email protected] Corporal Vendor

    145
    If you are doing it right the throttle won't close at all during a NLS... Power is cut to the coils so engine RPM falls and then when you release the clutch pedal power is restored. This happens within 1/50th of a second.

    Here is a log from the last SS using NLS on our 135i single turbo.

    attachment.php?attachmentid=55756&d=1477195358.jpg
     
    Last edited: Mar 9, 2017
  11. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    Just was curious.
     
  12. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    IMG_8331.PNG IMG_8332.PNG
    Ok so here's 2-4th gear pull. Mods are dp's, dci, meth kit, G5 ISO/mhd pump bef using Alaska's 90 octane. I noticed my car was running really rich on this run, also cylinder 1 timing is very low compared to the rest. Maybe a good ssk would help speed up shifts, the stock one is pretty clunky. IMG_8331.PNG
     
  13. Terry@BMS

    [email protected] Corporal Vendor

    145
    Throttle is fully open as expected. Post the CSV files so I can scan through it. Thanks
     
  14. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    I should have known better
     

    Attached Files:

  15. Terry@BMS

    [email protected] Corporal Vendor

    145
    Throttle looks fine. It's strange the fuel mode is jumping to open loop post shift, maybe that is part of what you're feeling. And timing is dumping a bit. What fuel/meth mix/nozzle setup?
     

    Attached Files:

  16. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    currently I'm using straight denatured alcohol because its dramatically cheaper than meth, 90 octane pump gas and a cm 12 nozzle.
     
    Last edited: Mar 9, 2017
  17. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    i did notice how rich it was running, 10 afr at one point, I'm pretty sure my pcv has failed i get smoke on decel and i have some oil consumption problems. i ordered an rb external lcv should be in soon
     
  18. Terry@BMS

    [email protected] Corporal Vendor

    145
    Enable the bank2 fuel trim logging under the FUD options, set meth safety mode = 1 (so it ignores history timing for its mapping), and lets see if we can get to the bottom of the fueling issue.

    We may also need to adjust the fuel scalar down in the BEF. Email me the file you have loaded and I can tweak that for you.
     
  19. AK135i

    AK135i Specialist

    78
    Anchorage, Alaska
    2010 135i
    ok ill go and do a couple more logs, as for FUD setting, do you just set it to 1? and i just have the ots pump map though mhd, how would i send that to you?
     
  20. Terry@BMS

    [email protected] Corporal Vendor

    145
    You have to click on bits and select the appropriate bit to output the extra fuel related data. It's bit5 and FUD will result in 32 after setting it.

    Just email me the file, or the full file name, as that also has the DME version required.
     

Share This Page