Misfires on cylinder 6 at high boost... weak hpfp ?

twinturbos

Corporal
Jan 1, 2019
145
Hi,
It seems like this is getting worse as I am now only able to boost at wastegate pressure without misfires. 17psi and 20psi misfires on cylinder 6.
I am thinking I have a weak and dying HPFP.
car is running the docrace single kit 6266BB, fuelit stage 2 lpfp, 94 octane.
Injectors, coilpacks, barely have 3000 miles, spark plugs have probably less than 1000 miles. Gapped to .022 I believe.
Here's a log today targeting 17psi:
 

noorj

10 Sec Club(N54)
Jul 12, 2017
126
Detroit, MI
that first log looks really rough. who is tuning it? how old are your o2 sensors? huge bank to bank deviation like that is either injectors or o2 sensors, and if you have relatively new injectors I would guess o2's. The second log shows multiple instances of the o2's reading <10, which is an implausible reading
 
  • 1Like
Reactions: twinturbos

twinturbos

Corporal
Jan 1, 2019
145
o2 sensors also have around 3000 miles. I am running JB4+MHD single turbo it is not properly(custom) tuned yet as I was waiting to get everything and trying to make sure it runs properly with everything.
First log I floored it and it misfired as soon as i went into boost :fearscream: and set a CEL.

that first log looks really rough. who is tuning it? how old are your o2 sensors? huge bank to bank deviation like that is either injectors or o2 sensors, and if you have relatively new injectors I would guess o2's. The second log shows multiple instances of the o2's reading <10, which is an implausible reading
 

Bnks334

Sergeant
Dec 1, 2016
324
New York
Hi,
It seems like this is getting worse as I am now only able to boost at wastegate pressure without misfires. 17psi and 20psi misfires on cylinder 6.
I am thinking I have a weak and dying HPFP.
car is running the docrace single kit 6266BB, fuelit stage 2 lpfp, 94 octane.
Injectors, coilpacks, barely have 3000 miles, spark plugs have probably less than 1000 miles. Gapped to .022 I believe.
Here's a log today targeting 17psi:
Rail pressure is tanking at boost onset... You're down to 1000psi. Reduce boost at this rpm range or find a way to get more fuel volume at low rpm.
 
  • 1Like
Reactions: twinturbos

martymil

Captain
Free Vendor
Sep 6, 2017
1,021
Down Under
I've been building and trouble shooting my mates single turbo setup for a while now and the biggest issue was the jb4.

Get your self a boost box and get yourself a custom tuner .

If you insist of using the jb4 talk to @trebila he is the best at these.

I would also get a shotgun kit as I fitted around 15 of these kits with no issues what so ever to help you with your fuel pressures but a double barrel kit
will see you never ever run out of fuel pressure, you will max out your stft's before you run out of pressure.

The missfire is due to something not set correctly in your tune, you need a custom tune.
 
  • 1Like
  • 1Informative
Reactions: 335is02 and twinturbos

twinturbos

Corporal
Jan 1, 2019
145
I've been building and trouble shooting my mates single turbo setup for a while now and the biggest issue was the jb4.

Get your self a boost box and get yourself a custom tuner .

If you insist of using the jb4 talk to @trebila he is the best at these.

I would also get a shotgun kit as I fitted around 15 of these kits with no issues what so ever to help you with your fuel pressures but a double barrel kit
will see you never ever run out of fuel pressure, you will max out your stft's before you run out of pressure.

The missfire is due to something not set correctly in your tune, you need a custom tune.
Thanks for your reply. The car was fine for the past 5000 miles running the exact same setup before this started to happen... once then 2 weeks later again and another couple of days later started happening every single day. I'm only running pump gas, waiting to figure this out before starting to spray meth... not planning on running E85 so doubt I'll need a shotgun kit. I'm just wondering if the hpfp is starting to be weak.
 

twinturbos

Corporal
Jan 1, 2019
145
Auto trans?
Manual

Little update, it seems water was dripping in that area from the windshield. Noticed a bit of rust on the coilpack and its barely a month old. Tried another coilpack and it still misfires at 20psi. I guess I will check the plug when I have a moment. Otherwise hoping I dont need an injector or an engine.
 

Cheezy

Lieutenant
Nov 7, 2016
598
Toledo Ohio
Manual

Little update, it seems water was dripping in that area from the windshield. Noticed a bit of rust on the coilpack and its barely a month old. Tried another coilpack and it still misfires at 20psi. I guess I will check the plug when I have a moment. Otherwise hoping I dont need an injector or an engine.
It might be the ol' dual mass flywheel issue. Google it for more information. If it were auto I'd have more advice. We've got a handful of people with cyl6 misfires we're trying to solve.
 
  • 1Like
Reactions: twinturbos

works

Private
Mar 1, 2018
34
It might be the ol' dual mass flywheel issue. Google it for more information. If it were auto I'd have more advice. We've got a handful of people with cyl6 misfires we're trying to solve.
I had a misfire at 6000-6500rpm that, after changing injectors (9->12, that was necessary regardless), plugs and coils, turned out the be the DMFW. Which I changed to M-factory SMFW and all my misfires went away. And as a bonus I got a driveline directness with the new zeroed out throttle filtration values that I never thought would be possible on this platform.

I'm completely fine using the 335is/550i springless clutch with the springless SMFW, it requires some concentration when driving. But YMMV.
 
  • 1Like
Reactions: twinturbos

twinturbos

Corporal
Jan 1, 2019
145
Thanks guys, I'm running the xclutch twin disk ceramic clutch so the flywheel shouldn't be an issue. Ran a compression test on it today everything is fine compression wise. Guess I gotta keep looking.
 

twinturbos

Corporal
Jan 1, 2019
145
Did a compression test. All is good. Also replaced the HPFP with a new one. Still misfires on cyl 6. I guess at this point I either need an ignition upgrade or an injector (has like... 3000-4000 miles on it :angry:)
 

Bnks334

Sergeant
Dec 1, 2016
324
New York
Why is AFR 2 so rich right at the point the misfire occurs? AFR 12.9:1 AFR2 10.9:1. TRIMS 2 is at 20%.

Edit: now that I think about it, AFR2 going rich could possibly be an "effect" from the misfires on bank 2 and not the "cause" itself. Then again, trims on bank 2 are high throughout the whole pull... so maybe something to look at there.
 

twinturbos

Corporal
Jan 1, 2019
145
Why is AFR 2 so rich right at the point the misfire occurs? AFR 12.9:1 AFR2 10.9:1. TRIMS 2 is at 20%.

Edit: now that I think about it, AFR2 going rich could possibly be an "effect" from the misfires on bank 2 and not the "cause" itself. Then again, trims on bank 2 are high throughout the whole pull... so maybe something to look at there.
Possible leaky injector ?
 

Bnks334

Sergeant
Dec 1, 2016
324
New York
Possible leaky injector ?
High trims means fuel is being added. Leaky injectors usually means rich condition at idle and negative fuel trims. Hence the white smoke out the exhaust when it gets bad.

Possible leaky injector ?
Can you swap O2 sensors on N54? see if the condition moves to the other bank as the O2 could be going bad like the other poster suggested. It's a shame JB4 pegs out at AFR 20. With MHD you can usually spot a leaky injector by looking at AFR on decel to see if it settles to 235.
 
Top