F1X Most Powerful built F10/N55 (535i)

  • Dark Theme is now available. Switch at the bottom of the page or in your preferences.

doublespaces

Administrator
Oct 18, 2016
6,672
AZ
#22
Yeah, I know the pain. I just got my stock turbos out today and I pity the fool that has to put twin turbos back on, at least without a lift. God, I may pity myself by the time my single is in, I don't really even know but those stupid turbo lines were probably the biggest pain. Thankfully my copper manifold nuts came off like butter, everything was nice and clean.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#23
I was able to get my stock turbo off with no problem this weekend, but discovered a problem on the replacement before we installed it. Getting that resolved now and will be re-installing next weekend. Being done in a garage without a lift as well, not terrible, but not ideal.

Also adding PI kit, replacing fuel lines, and replacing OFHG as well since they were starting to leak.
 

doublespaces

Administrator
Oct 18, 2016
6,672
AZ
#24
Nice! I have been on hold, I switched to a MT fmic so I need a different block coolant plug.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#26
They had the wrong arm on the waste gate. Not sure if was the wrong housing or just the arm. Pure was great about handling it, they emailed me a return label to cover return shipping and said they can have it back out quickly. I am still planning to finish the install next weekend. No complaints on how they are taking care of it.
 
Nov 19, 2016
37
Houston, TX
#27
Ah, well that sucks. Glad you noticed it before installing!

I may be jerking my turbo out soon to swap a different one in. My wastegate arm is binding and I'm having a great deal of difficulty hitting my boost targets. 80-85% WDGC at cruise, and pushing 90-95% to still slightly undershoot a 15PSI target.

I've exhausted all other possibilities, there are no boost leaks or vacuum leaks on the control sides. I swapped another EDPW in. No change. I pulled the wastegate rod out and manually moved the arm in the housing... its sticky/binding. Lubed the crap out of it which worked briefly until it burned off now its bad again.

No doubt Pure will exchange it, but having to R&R the turbo again.... UGH.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#28
I know you don't want to R&R the turbo again, but given your situation I would do that. You should easily be able to exceed 15PSI. I am getting that now with the stock turbo. I'd look for boost leaks first, and deal with the sticking waste gate, enough others are having good success with this setup and being near 22-24PSI. I think the 180 degree turn in the inlet is going to be a restriction. I wish someone made an aftermarket alternative for our chassis.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#29
Pure took care of my turbo and the replacement is in my hands, ready to resume install tomorrow morning. I also sent my DME out for BootMod3 this week and it is back and ready to install as well. Hopefully this is going to be a fun weekend!
 

doublespaces

Administrator
Oct 18, 2016
6,672
AZ
#30
Pure took care of my turbo and the replacement is in my hands, ready to resume install tomorrow morning. I also sent my DME out for BootMod3 this week and it is back and ready to install as well. Hopefully this is going to be a fun weekend!
Glad to see you got the bench flash done(as well as new turbo). There has seemingly been a lack of information regarding the unlock.
 

Shane303

Specialist
Nov 6, 2016
72
Mesa, Arizona
#31
Pure took care of my turbo and the replacement is in my hands, ready to resume install tomorrow morning. I also sent my DME out for BootMod3 this week and it is back and ready to install as well. Hopefully this is going to be a fun weekend!
I'm free tomorrow if you need/want any help Alan.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#34
Nice! Drivable this evening? A few of us are meeting up at the Pavilions around 6:30...
I doubt I'll be driving it tonight but close to complete. Just got the turbo mounted and its oil and coolant lines in. Still have quite a bit to do. New fuel line is run, E Sensor in place, still need to mount the PI plate and reinstall the intake manifold. Then all fluids need to get refilled.
 

Alan

Private
Nov 5, 2016
33
Gilbert, AZ
#35
Everything has been installed, but finished up late last night and didn't really test it out yet. Definitely want to put some heat cycles on it before really pushing it. Felt good from what I can tell so far. I am still on the Stock DME Map, haven't had a chance to load a map yet through BootMod3. I was running the JB4 on Map 2 as I had been before the turbo upgrade.

Overall the install took a little longer than expected. We did get a lot done, over about 2.5 working days. We definitely spent a lot of time making sure everything was done very clean, all lines and electrical run in proper channels, it looks stock when opening the hood (Aside from BMS Air Filter and ER Chargepipe).

I did learn the F10 Tow hook does not fit the cylinder head for using engine hoist, but E46 tow hook worked perfectly. I'm sure many others work but we had one available. Heat shields on passenger side were probably what seemed like burned the most time we didn't expect.

Replaced Stock Turbo with Pure Stage 2 w/GFB Diverter +
Replaced LPFP to Fuel-It Stage 2
Replaced Stock Fuel line from pump all the way to the engine bay with inline E-Sensor
Installed Fuel-IT PI Kit
Replaced OFHGs

Primed, heat cycled at idle, then drove for approx. 30 minutes last night with no issues.
 
Nov 19, 2016
37
Houston, TX
#37
Update is Carl & Tiago <3, 30psi on a PS2? uh huh....

Car got tboned by a kid with no license driving a family members car they were not insured on while playing with his phone who ran a red light.

Upgraded to a F10 M5.
 
Nov 11, 2016
68
Toledo
#38
You're a fan? That's awesome man. 30psi absolutely. Tapering to 24psi at redline. Feel free do look at any logs or my build to continue your education.
 
Nov 19, 2016
37
Houston, TX
#39
Not a fan, you know what I think of you.

My PS2 couldn't make 30psi with the wastegate wired closed and the EPDW bypassed so I don't know how yours is. The highest I saw was about 25.5 or 26psi. Maybe all of your throttle closure is why its boosting so high?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Top