Persistent 5D90 code

veer90

700HP Club (N54)
Nov 16, 2016
771
West Nyack, NY
5D90 is front left wheel speed sensor electrical defect. Replacing the sensor did not fix it. Disconnecting and reconnecting from car while running and restarting did not fix it. Clear the DSC module codes (through MHD or INPA) and it comes right back.

Any ideas?

Background:

ABS, DSC, and yellow BRAKE light came on 2 days ago when I started the car to drive home from work, and the code was intermittent. Clearing it would actually work for about 5-10 minutes before it came back. Initially, the codes were 5D90 and 5D96 (Drehrichtungserkennung vorne links - front left direction of rotation detection, or something).

Over 2 days it gradually got worse until now, where 5D90 immediately comes back if I clear codes. 5D96 has not come back since I changed the sensor.
 

AzNdevil

Corporal
Nov 4, 2016
214
Hong Kong
replace sensor ...clear codes....drive a bit.. if it still shows...clear again...drive... if it still shows... replace wheel bearing
 

veer90

700HP Club (N54)
Nov 16, 2016
771
West Nyack, NY
replace sensor ...clear codes....drive a bit.. if it still shows...clear again...drive... if it still shows... replace wheel bearing
I must have cleared the codes a million times at this point lol

Is it possible the ABS/DSC module itself is bad?
 

veer90

700HP Club (N54)
Nov 16, 2016
771
West Nyack, NY
Is it possible I have a short in the wire? A BMW tech I talked to told me to put a multimeter on the sensor wires to make sure I'm getting a voltage signal.
 

AzNdevil

Corporal
Nov 4, 2016
214
Hong Kong
you can test the sensor to see if its working by checking the voltage difference... you can check for shorts by checking resistance between the two wires

but if you ask me...i highly doubt it...
 

Andy_hastie

New Member
Mar 2, 2019
1
you can test the sensor to see if its working by checking the voltage difference... you can check for shorts by checking resistance between the two wires

but if you ask me...i highly doubt it...
Hi did you get to the bottom of this fault? I’m getting same code along with 5d96 wheel rotation code thinking bearing next was just checking incase it was module or bad wire?
 

Similar threads


Top