Possible DCT fault. Please help me.

  • Login or Register, members don't see Ads!
  • Tip: You can toggle the Dark Theme at the bottom of the page

General.Massacre

Specialist
May 14, 2018
59
Hi all.

My name is Justin from South Africa.
I'm having a frustrating issue which I cannot get to the bottom of. Seeing as you have a great DCT subforum here. And very knowledgeable members. I'm coming here for some much needed help.

The issue:
A few weeks ago. I did Stage2 turbos. Chinese Brand TD04L-16T.
After fitting car ran well and I popped a boost pip from IC to CP. Had it put back on and my mechanic apparantly did a DCT Gearbox reset (only found this out long after this) via Protool or whichever tool he used.
Got the car back and for about a week or two the car ran great and I was driving it well without issue.
One day I had WOT and the car bucked and lost power like a I popped the boost pipe again.
I checked everything and no boost pipe issue. Plus I still had full boost when I got onto the throttle again.
Everytime I go WOT now. Especially to log, I get the "throttle closure" issue.
I've now narrowed it down that it seems to happen when I exceed 5000 rpm. And mainly in 3rd gear. I havent done a proper log through 4th gear yet. But will test this when I have enough road.
The issue feels like the throttle closes. In my log I can see it, my throttle value dips and then all goes to shit.

Things I've done to troubleshoot:
Removed BMS BEF - still present
Removed JB4 - still present
Replaced Spark Plugs (oil in well 3)
Replaced new BMW Valve Cover at BMW
Replaced new BMW DCT Oilpan at BMW
Done DCT clutch Relearn Procedure at BMW
Installed a softer spring into my Tial BOV
Replaced Throttle Body
Flashed DCT with WinKFP to 8609092 ZSUB
Replaced new Vacuum Lines

My WGDC values in JB4 max out at 40%. So no boost leaks.
My fuel trims look good.
My AFR look good
Timing looks good

All the above is Map1 and I have a BMS Pump BEF loaded.
All firmware and BEF is the latest and all up to date.

I'm considering possibly changing either HPFP or LPFP. But my values are in the required range from N54Tech. So I dont think my issue is there.

I met with a BMW "DCT Specialist" at BMW dealer. And we went for a drive. He said that he feels the Clutches are out of sync and its causing the second clutch set from trying to come in while the first clutch is still operating. And says this is a software issue. But I'm not convinced.


My current mods:
JB4
BMS Pump BEF
Stage 2 TD04L-16T turbos
2inch Inlets
6" Intercooler
Charge Pipe w/Tial BOV
WMI with CM10 Nozzle
Upgraded Vac Lines (Platinum Cured)

I know there is Torque limits for the DCT box. But I highly doubt I am reaching this. Specifically since the issue happens when JB4 and BEF is removed also.
Could I be experiencing an actual DCT Gearbox hardware fault?
I'm considering updating the PUMP.bin I'm using to set the "Disable Tq Reduction by Ign" value and set the parameter to "00" as apparantly this is the recommended value for DCT.

I know I can get a custom flash. But dont want to spend for a custom flash yet till I can confirm this issue is not software related?

Please may I have your thoughts and advice if any.
If any other ideas on the BIN tables. There are other tables in the same XDF for the above "reduction by Ign" value in terms of Disable tq Reduction Path..."
Should these be set to the 00 value same as the OEM Software bin values?

Thank you in advance.
I'm really at my Wits end and have no idea where else to turn.

Justin.
 

dyezak

Major
May 4, 2017
1,768
Plano TX
Not likely to have a hardware fault. You need to pull a full ISTA+D diagnostics and post the output here for people to help you diagnose. Who did your BEF and what boost and fuel are you using?
 

General.Massacre

Specialist
May 14, 2018
59
Not likely to have a hardware fault. You need to pull a full ISTA+D diagnostics and post the output here for people to help you diagnose. Who did your BEF and what boost and fuel are you using?
Hi Derek.
Thank you for your response.
From ISTA+D do you mean the DCT Ckutch diagnostic. Or a complete entire vehicle diagnostic?

My BEF is the standard free BMS Pump BEF from N54Tech.
My boost is map1 and around 15psi.
Fuel is RSA grade 95octane. Similar to the USA 91RON.
 

dyezak

Major
May 4, 2017
1,768
Plano TX
First off, you need a real BEF. Those standard BMS flashes are fine for 6sp, or 6at, but aren't the best for DCT. They will work to get your up and going while waiting for a real BEF, but long term, they won't be the best for your DCT longevity. That said, it is not the problem you are having here. Not on 91RON and 15psi.

Yes, run the entire vehicle diagnostic.
 

General.Massacre

Specialist
May 14, 2018
59
First off, you need a real BEF. Those standard BMS flashes are fine for 6sp, or 6at, but aren't the best for DCT. They will work to get your up and going while waiting for a real BEF, but long term, they won't be the best for your DCT longevity. That said, it is not the problem you are having here. Not on 91RON and 15psi.

Yes, run the entire vehicle diagnostic.
Understood. Thank you. Will arrange with the likes of Trebila for a custom flash. Unless you know anyone better for DCT?

I will go see BMW on Monday and get the full printout. Then scan it to attach here.
 

aus335iguy

Captain
Nov 18, 2017
1,036
The JB4 is a complicating factor. You say that the issue occurs with it removed as well? How many miles on the car ? Did the problems present before the clutch relearn and the other DCT work?
 

aus335iguy

Captain
Nov 18, 2017
1,036
Reading the sequence of events it looks like it started after your mechanic did a reset ? What EXACTLY did he do?
 

General.Massacre

Specialist
May 14, 2018
59
Reading the sequence of events it looks like it started after your mechanic did a reset ? What EXACTLY did he do?
Good morning sir.
That's correct. It happened a about a week or so after he reset the Gearbox. I found out about it only a mo th after through a friend.
When I asked him he said "was just a gearbox adaption reset". And that was the end of it. I cannot give anymore detail than that I'm afraid.

It concerns me as I know the DCT is pretty delicate already.

Thanks in advance.
 

aus335iguy

Captain
Nov 18, 2017
1,036
I would suggest getting someone who knows how to do the DCT adaptation reset properly take a look.
 

General.Massacre

Specialist
May 14, 2018
59
I would suggest getting someone who knows how to do the DCT adaptation reset properly take a look.
I've had it at BMW on Wednesday for the DCT OilPan replacement. And they say they did the adaption reset after the oil top after the work was completed.
I'm not sure of any specialists otherwise. Would have to ask around and find this out.
 

General.Massacre

Specialist
May 14, 2018
59
Hi guys,
havent been to BMW, coz they say they fully booked, and need my car for at least 2 days to do a full diagnostic scan on the car to check everything. so ive not gone.

Ive been paying more attention to my logs, and have looked at the HPFP values.
the FP_h value is not stable, its up and down very erratic. with the occassional dip into the 9's.

could this be a tell tale sign that my HPFP is not dealing with the fuel demands? my LPFP is stable, however readings vary from log to log, not always the same value range.

So 2 options here, either the HPFP is taking a dump. or, the LPFP (Mine is stock), is struggling to supply the HPFP at high RPM? even without the JB4 and BEF installed.
Could i be correct here? i know you dont have disagnostics, but i cant get anything right now. i did post Datazap above if you need to look.
 

aus335iguy

Captain
Nov 18, 2017
1,036
I dont know how to read JB4 logs at all. As in i know what the lip and HP pressure numbers should be in MHD but not in JB4.
 

General.Massacre

Specialist
May 14, 2018
59
Hi all. So I want to update this.
Solved.

The issue was the Left Side Engine Mount.
It was completely loose. And by loose I mean all for bolts holding it to the block were loose.
We threaded them all in by hand about 6 turns each. Then only used the Rachet to tighten it up.
Test drove this evening on JB4 Map1. And the car is smooth and solid. Holds 15psi and tapers to 14psi around 6000rpm.

Next up will be to refill my Meth tank. Then get a LPFP upgrade and a Trebila custom tune for my DCT.

I'm still teaching myself TunerPro. But for now custom tune may be best.
 

aus335iguy

Captain
Nov 18, 2017
1,036
Wow. I wouldn’t have thought that an engine mount would do such a thing. Glad you got it sorted
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top