RB external PCV setup

Panzerfaust

Lieutenant
Jul 3, 2018
504
Chicago
@Panzerfaust please post what you find when you pull it off, please.

Filippo
Will do! I have neither PI nor the head plugs installed, just lots of venting on the high side (3 vent points) and a customized low side similar to yours so I'm expecting better results than most without the ports plugged, but probably not quite the level it *could* be at obviously.

My ports will likely get plugged eventually since I have some internal engine parts I need installed, I just dont know if I want to delay it longer so I can get an M18 VC or go with the plastic OE again. With all my venting I'm not worried about the VC itself cracking anyway, so I don't know if a metal VC will do much more than look fancy and make me change my PCV setup which isnt really what I want to do at this point. However the idea of never having to buy another VC for any reason whatsoever is also enticing.
 

Panzerfaust

Lieutenant
Jul 3, 2018
504
Chicago
@Panzerfaust please post what you find when you pull it off, please.

Filippo
So I know I'm a few days later than promised, but some personal stuff came up the last few days and I had to put my product install on hold but heres the pictures.

This is after probably 18months/~25k miles, with the first 6 months being just the RB kit and then the other 12 being my customized low side and VTA high side, the last ~8 of which I've had the high side venting from several outlets. No head ports blocked. My cylinder 1 is the dirtiest you see here which is in line with what happened when I got my intakes walnut blasted, but the others dont look half bad imo. I apologize for the image quality, it was taken on my phone late at night so lighting isnt great nor is the resolution but you get the idea.
 

Attachments

  • Like
Reactions: fmorelli

matreyia

Captain
Apr 19, 2017
1,105
So I know I'm a few days later than promised, but some personal stuff came up the last few days and I had to put my product install on hold but heres the pictures.

This is after probably 18months/~25k miles, with the first 6 months being just the RB kit and then the other 12 being my customized low side and VTA high side, the last ~8 of which I've had the high side venting from several outlets. No head ports blocked. My cylinder 1 is the dirtiest you see here which is in line with what happened when I got my intakes walnut blasted, but the others dont look half bad imo. I apologize for the image quality, it was taken on my phone late at night so lighting isnt great nor is the resolution but you get the idea.
That's not bad at all. No need for a walnut blast again. What's up with the gooey fluid stuff? Mine did not have any film or residue fluid when I checked.
 

Panzerfaust

Lieutenant
Jul 3, 2018
504
Chicago
That's not bad at all. No need for a walnut blast again. What's up with the gooey fluid stuff? Mine did not have any film or residue fluid when I checked.
I would assume it's just residual oil/blowby from prior to the external PCV installations, my chargepipe and CP to IC silicone had no oil buildup but my IM hasn't been taken off in quite some time - much more than the amount of time that I've had any upgraded PCV system.
 
  • Like
Reactions: matreyia
Top