What is the next upgrade?

  • Login, members don't see Ads!

typedRew

Corporal
Feb 25, 2019
126
We can just meet at that gas station on Woodward and drive in. I’ve never been to lapeer so that’ll help.

Weren't people having issues with running on a 2wd dyno with xdelete? Depending on where I'm at with some maintenance items I might try to make it out to that.

edit: xhp now recommends letting the clutch cool off between multiple runs on 2wd dynos.
Interesting. Well, it’s only two pulls, I doubt it’ll be much issue. If anything one pull is good enough for me. It’s a basically stock car, not like I need to adjust the tune between runs.
 

1Goodfella

Private
Nov 27, 2018
34
Yeah that rear inlet install is hell, you can always double check it as sometimes it might look like the clamp is well connected but it's not, it happened to me once and the car was acting weird. Did you check your vacuum lines?
What spring do you have? it's better if you can upload a log as that will be more helpful.
Hello sorry I didn't see the email notification.. so I checked all my vacuum lines. I questioned about the spring weight in the tial bov... I actually contacted tial. They said that spring q black series can handle 1800hp.. they told me to manually check the negative boost psi.. I haven't had time to do that. I know in my mhd at idle is pretty consistent at -11.5. I about getting heavier spring. They said that shouldn't affect it.. I mean if I knew I needed a tune..I would have waited to get updated twins and so the inlets at the same time. Let me get in my laptop and I'll upload a log on data zap... Mhd said the ots are not intended for inlets and would need a custom tune.... Thoughts on this.
 

1Goodfella

Private
Nov 27, 2018
34
hey guys, im sorry to thread in here. Iv been having an issue and the last thing that was done was Vrsf inlets...i was having some issues or i thught i was a month or so ago..which i did a log, so i have a baseline to compare it to..

So i have 07 335 manual gearbox, with complete vrsf FBO with vrsf charge pipe and Tial BOV .. Running stage 2+ MHD flex fuel around 40%. Cars been running great the past week i did install on inlets and it was a bitch... To get that rear inlet on that small flange of the turbo was insane.. we got it clamped on there very tight... Anyways... On my way home i was on the high way.. maybe doing 50mph... maybe 4th gear wot to hear the difference and almost felt like surging..... again i tried in mid-high gear, low rpm and felt like surging again... has anyone had this happen.. i am stock turbos... No codes are being thrown... i can upload datazap before and after 3rd gear pulls.. I also contacted tial about maybe changing spring on BOV..


Any thoughts anyone. Thank u
here is a log and will send another https://datazap.me/u/goodfella607/3rd-gear-2k-pull-wot?log=0&data=2-3-13-22
 
Top