E89 Z4 Track-ready Sleeper Build

  • Login or Register, members don't see Ads!
  • Tip: You can toggle the Dark Theme at the bottom of the page

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
To reflect further on the above. My problem really is, that I do not know what my problem actually is. I just know that the problem is getting smaller, but that I still have a problem.

More data is needed.

Lets go back to the basics, what is needed to keep the engine cool:
A) The radiator must be large enough for the air flow and temperature available = Increase radiator size, use a more efficient radiator or increase flow.
B) The coolant flow through the radiator must be high enough = Increase pump power or reduce resistance to flow.

So how do we determine which problem it is?
1) We measure the coolant temperature differential over the radiator. If too large, flow is too small.
Let's say the coolant flowing into the radiator is 120C, and what comes out is 60C. Then increasing the flow would perhaps produce 100C in and 80C out. This would mean the difference between limp mode and happy mode. Given that the S55 moved to a mechanical coolant pump, and given that we have yet to see any bmw 3.0T engines with electric coolant pump that don't overheat, I find it highly likely that this is where the mine of gold is hidden. If the coolant temperature differential is small, then I can move on to below.

2) Measure the air temperature differential over the radiator. Shouldn't be too small or too large.
This would mostly serve to find how ineffective stacking radiators really is. The S55 radiators are not very thick. Mine are. Maybe that is bad, although I am seeing improvements. Or maybe what I have done is okay for the track, where the air flow is large, while the S55 was optimized for city sprints. Who knows.

3) Measure the air pressure differential over the radiator. The larger the better.
This would indicate how well the air scoops are working, and if the air is able to escape behind the radiators. Best would be to compare with an M car. The M2C/M4 design is not very different from what I have - we already improved the air scoops. The engine bay is arguably even more crowded on an M2C or M4. I even have the snorkle removed, so the intake helps create a vacuum behind the radiators. Also there is no major difference between the M2 and M2C in terms of air flow in and out, yet the cooling performance is very different between the two.

I'm getting in contact with a racing team to see if I can borrow some equipment for a track day or two in July or August. Not sure if the coolant differential can already be seen with ista or similar?
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Have taken a few steps forward with the build:

Data logging
I have asked AiM to quote the following
  1. Temperature sensor. To be used to log coolant temperature at engine inlet. The purpose of this is to learn if the coolant flow is adequate.
  2. Oil pressure sensor. This to log oil pressure at oil cooler inlet. The purpose of this is to check if my semi-dry oil sump is working when I use slick tires.
  3. Tire temperature sensor. Here I just want to install one sensor to log the front right tire temperature. This is just for fun, and to learn more about how tires work.
With some luck, the accessories should be here end of july.

Tires
So after getting the extra set of wheels and Pirelli medium slicks, it occured to me that sometimes the weather is not suitable for slicks. And if I can handle to ship and store one set of extra wheels at a track, I can also handle two sets. So I started looking into wet tires.
As it turns out, there are lots of super soft competition wets, and lots of rain-capable street tires, but not much in between. I wanted something street-able that I can use to set good lap times in the rain. The choices narrowed down to
  • Michelin PS4S, 300 threadwear
  • Toyo R1R, 200 threadwear
  • Competition wets (such as Kumho, Pirelli Wet Hard, Wet Soft etc), not street legal, very low threadwear
Since everyone I compete against use PS4S or similar street tires in the rain, I decided to go with the Toyo R1R in a narrow 225 width. This means I now have three sets of wheels and tires:

Dry setup (time attack): Squared, Pirelli DM slicks, 245-645-18 , 9J18et30
Street/practice setup: Staggered, AD08r/cup2/rs4 235/40R18 8.5J18et35 front, 265/35R18 9.5J18et40 rear
Wet setup (time attack): Squared, Toyo R1R, 225/40R18, 8J18et29 front, 225/40R18, 8.5J18et40 rear
 
Last edited:
  • 1Like
Reactions: NoQuarter

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Why narrower on the wets?
To resist hydroplaning.

In the end I couldn't get the R1R tires, and no PS4S in 18in either. So ended up getting cup 2 in the same 225 size instead. I think they will work well as intermediates as long as I am able to get them warm enough. At least better than 245 slicks when there's risk of standing water. They are likely not suitable for the heaviest of rain, but at least I don't need to worry about them overheating as the track dries up. I wont be using them on the road, so the thread should be deep enough when I need them.
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
To resist hydroplaning.

In the end I couldn't get the R1R tires, and no PS4S in 18in either. So ended up getting cup 2 in the same 225 size instead. I think they will work well as intermediates as long as I am able to get them warm enough. At least better than 245 slicks when there's risk of standing water. They are likely not suitable for the heaviest of rain, but at least I don't need to worry about them overheating as the track dries up. I wont be using them on the road, so the thread should be deep enough when I need them.
1160970873.jpg


Above are some results obtained from running different tire width combinations with a low power BMW. The square 225 setup is neither here nor there. Unfortunately hydroplanning resistance wasn't part of this particular test.

Made a new summary with pics to visualize what I have decided to run below. This weekend is time attack at Zhuhai International Circuit. Weather forecast is rain, and only semi-slicks are allowed. It is a high speed power circuit with lots of heavy braking zones, so it should be the perfect weekend to try the brand new cup2s.

SetupSlick, dry
Competition only
No limit class
Semi-slick, wet
Competition only
Treadwear 100-200 class
Street, dry/wet
Free Practice
Threadwear 200+ class
TirePirelli DM (race scrubs)Michelin Cup 2Yokohama AD08r
WheelCast 18inCast 18in (OEM)Forged 18in (Custom)
Front dimensions245-645-18, 9J18 et30225/40R18, 8J18 et29235/40R18 8.5J18 et35
Rear dimensions245-645-18, 9J18 et30225/40R18, 8.5J18 et40265/35R18 9.5J18 et40
Pictures
1069335580.jpg


2082678422.jpg
2030858401.jpg


cup2.jpg
ad.jpg


854411828.jpg


We are currently trying to finalize the new aluminum under plate. We added protection meshes to the aux cooler outlets, and now trying to figure out how to make NACA ducts for brake cooling.

731007270.jpg


We have also installed a 120W version of the booster pump with 3600l/h flow to run the three aux radiators.

A few other issues that I have been dealing with:
  1. VTT Aluminum charge pipe hose clamp going loose again and again. The charge pipe outlet has become a bit triangular in shape, and apparently that might be the root cause. Today was the fourth time we found the clamp to be a bit loose and had to tighten it. We have now added an extra bolt to the clamp and marked the bolts with paint to see if they move.
  2. Sparkplugs going loose. Yesterday we found 4 out of 6 sparkplugs to be a bit loose. This is the third time in less than 2000km I get either misfire or spiky stft due to this. We have now torqued them to spec with the proper tool, and hope this solves the issue.
 
Last edited:
A few other issues that I have been dealing with:
  1. VTT Aluminum charge pipe hose clamp going loose again and again. The charge pipe outlet has become a bit triangular in shape, and apparently that might be the root cause. Today was the fourth time we found the clamp to be a bit loose and had to tighten it. We have now added an extra bolt to the clamp and marked the bolts with paint to see if they move.
  2. Sparkplugs going loose. Yesterday we found 4 out of 6 sparkplugs to be a bit loose. This is the third time in less than 2000km I get either misfire or spiky stft due to this. We have now torqued them to spec with the proper tool, and hope this solves the issue.
1. locktite blue time??

2. What plugs are you running? Thinking back to Filippo's spark plug conversation about some having reusable crush washers and some having one-time use versions.
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
1. locktite blue time??

2. What plugs are you running? Thinking back to Filippo's spark plug conversation about some having reusable crush washers and some having one-time use versions.
Yes I agree on the plugs. The problem apparently was that the washers weren't even crushed probably to begin with. Now they are, and so far the problem hasn't returned.

As for the clamps, my tuner says im overboosting now, so I guess we're good there. But my iats run past +100C / +220F on track, so I need to look into more heat shielding and perhaps water injection when I am done with the radiator flow/pump flow diagnosis to find the root cause of my increasing coolant temps.
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Oil pressure sensor and post radiator water temperature sensor are up and running! Now I just need a track day to determine if I am OK running slicks, and to see weather the stock water pump is under-dimensioned or not.

1962349077.jpg


I had a bracket made so that they install on the same suction mount I normally use for the AiM Solo 2 DL (which unfortunately isn't compatible with external sensors, need the AiM MXm for that - doh!! )

We also made it so that the sensor cable can be unplugged and hidden in the small compartment next to the steering wheel when not needed. This is also where the button for the semi-dry oil sump and dct/aux rad cooling pumps is hidden. So it still takes no time to reverse everything to a 100% stock looking cabin.

724436322.jpg


I did a test while cruising on the highway, and saw a +10C temperature drop when I turned on the aux radiator pump. The oil pressure sensor also seems to work. I saw 60-70psi when cold starting, then around 30psi warm at idle. When accelerating slowly it jumps to around 90-100psi, and I think I saw +120psi at around 4500rpm. No idea if this is normal, but those are the first data points. Currently running 5w40 amsoil LL04.

Oil pressure sensor:

246721772.jpg


Water temp:

767678402.jpg


And speaking about oil. My differential is starting to make noises again. As some of you might know, my first differential started whining due to improper installation of the quaife core. I then got a new diff, and had the Quaife core installed again - this time properly. As of today, there is still no diff whine like last time, but it is starting to have more and more slack, and there's some sound when setting off in 1st. It started after a 1hr track event, and I am told it is because I used BMW oem diff oil (as recommended by the Quaife importer). Apparently it turns to water when the diff gets hot from prolonged track use. So I should have used this instead

1198045744.jpg


So I changed to that to limit further damage, but will still have to get the diff opened and repaired asap.

And speaking of overheating, these are the next steps towards lowering iats a little:

515722076.jpg


Before:

963072776.jpg


After:

1906641215.jpg



And finally my tune has been is finished. Yay! Ended up going through a total of 26 revisions. Got delayed and side tracked alot due to numerious issues. Vanos issues, different cat setups, different FMIC setups, tmap boost leaks, charge pipe boost leaks, exhaust flap not working, ignition issues, spark plug issues, injector issues, LPFP giving up etc. The list goes on.

Finally @BQTuning settled on 18.5psi and 5-8 degrees timing with local pump gas (Chinese Ron 98). What I really love about this tune is how flat and predictable the torque delivery is. I can balance the car super precisely on the limit of traction on corner exits. And the combination of low lag and a good top end that pulls slightly on M4s is just perfect for my use. I also love that fact that BQ used all the track logs I did to add safety margin and develop a tune that works even when things get super hot. Now it is just up to me to further improve the cooling system to add further safety margin.

Below is the log and VD curve.


final-vd.jpg
 

Attachments

Last edited:
  • 1Like
Reactions: TDJ Stefan

AndyW

Lurker
Jul 17, 2019
10
My main concern is actually the DCT, because I don't know how well it is cooled by the heat exchanger, and the M cars have separate oil coolers for it. The M4 GT4 even uses the M6 transmission oil cooler, although all other coolers are standard M4. But so far I have never had problems with the DCT.
Do you know what the max DCT temp is? I've never hit limp mode but this thread made me go look at a log from last year and DCT temp got to 200F on a track day. What do your DCT temps run with this setup?
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Do you know what the max DCT temp is? I've never hit limp mode but this thread made me go look at a log from last year and DCT temp got to 200F on a track day. What do your DCT temps run with this setup?
I saw 226F peak transmission temperature yesterday after two hot laps at Zhejiang International Circuit. This is probably the worst I have ever seen for the DCT. It was a hot and humid day. 35C according to the weather app, +40C/104F according the cluster. Was pushing super hard to win the time attack.

mmexport1563680336487.jpegmmexport1563686874286.png mmexport1563708064947.jpegmmexport1563708103990.jpegmmexport1563708123350.jpeg


Mind you this is with the large SSP DCT cooler running full speed. For more logs just search for "temp" in my datazap archive


I have never had any DCT temp warnings, and all of the logs are with the SSP system turned on. Unfortunately I did not log DCT temp during some of the super hot 1h endurance races we did. It seems the transmission gets warm much later than everything else, so the temps might have been running higher then. I hope not, but they might have. Will report back if I ever do a 1h stint again.
 
Last edited:
  • 1Like
Reactions: AndyW

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Doing a few updates these days. Say hello to the new radiator family:

790658324.jpg


The CSF is old, but needed some cleaning. The square cooler is going on to the drivers side, and the wide one will sit behind the new FMIC.

1436239295.jpg


I decided to go with a tall rather than deep FMIC and add water injection to lower iats and hopefully keep the engine and turbos happier during track use.

Here's an overview of the new radiator situation compared to old, stock and S55.

newcooling.jpg


In conclusion the car should get close to the S55 in terms of effective radiator frontal area, while reducing some overall thickness. Main downside is that more of the radiator area will be covered by the FMIC. The same is actually true for the S55, but it uses a water cooler instead, which allows for more airflow to the radiator behind.

We are also making a new oil pan baffle, because tests showed that oil pressure would drop during left hand turns when using slicks.

1365375207.jpg


Finally we replaced the RTABs with bearings instead of the M rubber + limiters

1677016633.jpg 1253056095.jpg 1855209075.jpg

Other small changes being made
* adding a 2nd snow performance kit to spray in front of coolers (manual operation)
* adding thermostat control of the DCT oil cooler (on at 100C, off at 95C), so I do not have to operate it manually.
* modified the rear turbo compressor housing to make it less likely that the hose coupler gets loose.
* replacing motor mounts with revshift black or green depending on test results

New overview

overview.jpg
 
Last edited:

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
New coolers are in. Here's a quick video comparison between the new and old cooler setup


Here's a close up of the 60mL nozzle for outside water spray.

1036581840.jpg


Here's the 375mL nozzle used for water injection at +10psi.

183548886.jpg


Below is one of the new aux radiators installed

113648265.jpg


Also added the intake snorkel back in (as recommended by @RSL)
This was possible now as the large aux radiator has been removed.

1671941476.jpg


Here's the new oil pan baffle with one-way door. The red circles are where the small oil cooler is connected with a pump.

574496702.jpg


Looking forward to see if the oil pressure still drops on left hand turns with this baffle.

And finally here's the DCT oil pan 3/8npt thermostat that now controls the DCT oil cooler pump. This so that I do not have to turn it on and off manually. It should turn on at 100C and off again at 95C.

186657948.jpg


We also installed the revshift motor mounts (black), but I do not like the massive NVH, so we will try reinstalling the OEM driver's side mount to run only revshift on the passengers side.
 
  • 1Like
Reactions: RSL

RSL

Sergeant
Aug 11, 2017
395
If you have room for scoops without inference, get some ASAP. Stock air box with scoops and inlets works so well on road even with crappy used paper filter, I left it in.

Looking forward to results on the new cooling setup.
 

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
For those interested in the performance difference between the smaller VRSF and the ER competition FMIC for M235i, I made a post here comparing iat data on 3rd gear pulls.


When I have had the chance to test on track I will post that data as well.

We also managed to eliminate some boost problems. Here's a virtual dyno comparison between the old and new setup cooler with water injection.

ny-vs-gammel-turbo.jpg


I can also report that using the driver's side OEM mount in combination with the revshift black type mount is an awesome combination. I still need to run 900rpm idle to be able to live with the NVH, but the car feels a lot better to drive compared to stock mounts. It is incredible how much this has transformed the feel of the car. Now Im curious how the car would feel with the revshift green poly on the passenger side only. I could even try a combination of the green and black poly on the same engine mount.

latest.jpg
 
Last edited:

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Minor update on the build. I am still waiting for a good track day opportunity to test the new cooling and oil pan setup. I expect to get a chance to do so on October 5-6. I am especially curious to see if the 2nd aux rad offers any cooling benefits as it sits behind the FMIC. I have a ball valve on the hose going to it, so I can do A-B testing quickly on track.

overviews.jpg


I did a few pulls on the road in 32C / 90F ambient and while it is already evident that the larger FMIC + water injection is beneficial, I can still see the water temp fluctuating, which is not a particularly good sign.




Anyway, we broke the two quick connectors between the engine and main radiator while working on the new cooling setup. For the engine side I found an aluminum version in red as seen below:

Clipboard01bbbb.jpg


I liked it so much that I had the radiator side connector custom made in aluminum as well by sending in the old broken connector:

Clipboard01bb.jpg


Three weeks later they finished production:

mmexport1569500788218.jpg


They made three, so if anyone else is interested let me know... they cost around RMB 220 here in China.


IMG_20190924_153757.jpg
 
Last edited:
  • 1Like
Reactions: NoQuarter

Asbjorn

Sergeant
Mar 10, 2018
492
European, based in China
Another quick update on the build.

Been working on an issue we found were stfts would flatline post shift. I made a separate thread about that here. It was especially bad when running WI, and would cause hpfp to dive, loss of power and the occasional misfire due to afrs going rich. We are tuning around the issue, and I might add WMI during testing to further bulletproof the tune.

I do have one problem with my WI setup no matter what, and that is the fact that I am using the windscreen washer fluid tank. I have expanded the volume of the tank because there was plenty of space next to it in the Z4, but the problem is that it is right next to the turbos. Now given the cast manifolds of the GC lites, the engine compartment gets super hot. It doesn't matter how well I have the manifolds heat shielded, it is still much hotter in there compared to OEM. And this means the water gets warm. And using hot water to cool iats isn't ideal. The only permanent solution I can think of is upgrading the tank to an insulated one. As a temporary solution I might just have to throw ice-cubes in there during track days...

As for the semi-dry oil-sump - that system is still undergoing testing and development as documented here.

Fortunately I am super happy with the new cooling setup. I described the testing results here and here. I want to do one more test comparing peak coolant temps with the 2nd aux radiator turned both on and off before I permanently delete the ball valve. The previous test was a bit sloppy due to red flags. But no matter what, again huge thanks to @shushikiary for helping me select the right hose IDs and radiator cores for the new setup. The car is finally beating caymans, M2s and M4s in terms of time-to-overheat on track, which is a huge achievement, given the power level.

And speaking of power, just did a 9.4s pull from 100-200kph according to datazap. Seems car has picked up a bit of torque as the whether is getting cooler. Anyway I am happy as long as it is a fraction faster than the M-cars I compete against.



vd.jpg


Finally a comment on the 225 cup 2 tires I mentioned further up. I intended to use those for track driving in the wet, and I just have to admit they are too narrow. I have not met a single racing instructor that agrees with my choice, and there's just a limit as to how narrow you can go given the power my car offers. It seems a much smarter choice for wet time attack would have been PS4s in a square 255-265 setup.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top