First Drive Powerglide Single Turbo

Brule

Corporal
Feb 20, 2017
189
Definitley need to do some skids.
The tyres are to big on the back so im scraping. I went wot the other day and shredded the side wall of the tyre.

I adjusted the rear suspension a bit higher now and ive done some transbrake launches but let off as I knew it woul just spin.

Cant wait to feel the boost.
 

Brule

Corporal
Feb 20, 2017
189
Did a few sessions testing pump fuel.
Its pretty laggy as you would expect with a 76mm journal bearing.

Boost has been under target by 2-3psi on lower maps and just gets bigger on higher maps.

It wasnt really exposed on the 6266 but the wastegate pipe must have a leak or im down on compression.

I tested map 1 -5.
Boost builds slowly and inconsistently.
Sometimes 12psi at 5000rpm sometimes 20psi at 5000rpm. Even back to back it changes.

Even on map 5 targeting 26psi it only hits 22psi. The target is way higher than actual boost. With the 6266 is was near perfect on target on map 2 and 3 with simple changes.

Started trying map 6 with reasonable targets for the turbo, did 2 runs and popped an O2 sensor. So I limped it home.

The 7675 is much laggier and the ff isnt doing anything so Ill have to ask for help off Terrys crew.

I did a smoke test of the turbo to intake, no leaks.
I need to check wastegate plumbing as I think theres a leak I can hear. Exhaust doesnt sound as crisp and punchy as usual.


Photos of turbo.

Heres a transbrake test. Map 2 17psi.
Ive had a few runs at 22psi and it rips a fair bit harder. Ill get a video soon.


 

Attachments

Brule

Corporal
Feb 20, 2017
189
The 6266 gets up to 4500 pretty quick and spins. It spins from a standstill to.

Hopefully the journal 7675 can spool a bit quicker on e85 or ill be getting my 7th different turbo.
 

rac

Corporal
Nov 14, 2016
216
Australia
does it behave consistently up to your WG spring pressure?
check your logs for throttle closures and other odd stuff that might have coincidently popped after the new turbo install.
 

Brule

Corporal
Feb 20, 2017
189
Ive done around 20 wot logs on the 7675 and the wgdc has spikes. Sometimes it has throttle closures but the wgdc is random and has spikes.

The wgdc has spikes low randomly and makes boost drop off.

Sometimes before wastegate presuure of 14psi and sometimes after.

I have not tested enough to know the cause.

All I know is the hotside has a leak and possibly cold side.
I have smoke tested hot and cold side with a home made smoke tester but it must need more pressure to see the leak.

I will find the leak.
 

Brule

Corporal
Feb 20, 2017
189
Car has been running well no issues.

Wanted to share my latest results with the car.

Done 1 roll racing event and had alot of fun racing all kinds of cars and power levels. Raced most of the night on 17psi then changed to 20psi for a few. Got beaten by 2 pretty powerfull cars. 830kw supra manual and a 700kw LSX turbo ute with a T400.

Been trying to get some good 60fts.
Grip is the issue.
PB 1.97 ft and a 3.75 second 0-60mph
330ft 5.03 which is knocking on a 10 second pass. This is on 17psi 10 degrees adv.
Video of PB

 
  • 1Like
Reactions: doublespaces

Similar threads


Top