E9X Suspension squeaking over bumps

veer90

700HP Club (N54)
Nov 16, 2016
765
West Nyack, NY
So my rear suspension squeaks over speed bumps, potholes, etc. Yesterday we had a snowstorm in NY and I dug my car out from under 1.5 feet of snow... lo and behold it stopped squeaking. Update: humidity related, has nothing to do with the weight of the snow.

A mechanic friend said the top hats might be worn and causing the noise. Otherwise the car launches, turns, and stops perfectly. What do you guys think?

I replaced all the arms in the rear except for the main lower spring / shock perch (M3 control arms, rogue engineering toe arms, and ECS billet trailing arms). Recently just checked all the bolts and all were tight. KW V3 coilovers with about 20k miles and no signs of leaking shocks.
 
Last edited:

doublespaces

Administrator
Oct 18, 2016
6,944
AZ
Was the snow heavy enough to make it squat? If not, the only thing I can think of is some sort of moisture lubrication?
 

NoQuarter

Lieutenant
Nov 24, 2017
912
Indiana
On the 5 series, in the front, it is always the front sway bar bushings that squeak in the cold.

Not sure if it helps but may get you thinking of something similar
 
  • Informative
Reactions: doublespaces

veer90

700HP Club (N54)
Nov 16, 2016
765
West Nyack, NY
Update: seems to be humidity related, not related to the weight of the snow. It's been raining on and off here for the past few weeks and it stops making noise for a few days after it rains.

When it dries out it will always start squeaking again. Spring/shock perches, or main carrier bushings?
 

NoQuarter

Lieutenant
Nov 24, 2017
912
Indiana
Update: seems to be humidity related, not related to the weight of the snow. It's been raining on and off here for the past few weeks and it stops making noise for a few days after it rains.

When it dries out it will always start squeaking again. Spring/shock perches, or main carrier bushings?

Didn't matter, new or not. Try some lube in the sway bar bushings; easy enough to try.
 

Rob09msport

Lieutenant
Oct 28, 2017
859
Monroe CT
Wondering how you fared. Also do you have adjustable end links and you could loosen and retorque all arms in rear as they should be loaded when installed. I never knew this until this platform and assume many others don't as well.
 

Rob09msport

Lieutenant
Oct 28, 2017
859
Monroe CT
Curious what grease you used some say marine grease but Mobil 1 synthetic says won't wash away either and Is suitable for more applications ie wheel bearings
 

Similar threads


Top