What is destroying sparkplugs in my engine?

  • Dark Theme is now available. Switch at the bottom of the page or in your preferences.

sch4400

New Member
Mar 20, 2018
9
#1
My mod.

6266 single turbo.
fuel it stage 3 FUel pump
fuel it PI kit with bms controller and return line.
Precision racework coils and ngk 97506 gapped 0.022 (use dielectric grease)
fuel : e85.
mhd custom flash map with jb4.
1 meth cm7 meth nozzle at charge pipe.
compression ratio chaged 9.4:1 from stock.
forged connecting rod
forged metal bearing.

6 weeks ago, I got misfire on cyl 2. so I checked spark plug first...the center of insulator was broken.
I just replaced a new plug on cyl 2, after that got error code 30ba.
so I repaired dme mosfet.
car was fine on IDLE.
but still issue on cyl 2 when WOT.
always misfire on cyl 2.

I though it was leaky injector..so..swaped DI injector between Cyl 2 and cyl 4
but.. still misfire on cyl 2.
did swaped precision coil between cyl 2 and cyl 3. same issue on cyl 2.
after swaped PR coils...got new error code which is ignite error code.
so I just replaced new PR coil on cyl 2.

also I swaped PI injector between cyl 2 and cyl 5.
after that got new error code misfire on cyl 6.
so I though it was leaky PI injector.
but yesterday I got misfire code again on cyl 2 while normal driving on highway.


2 times broken insulator on cyl 2
1 time burned(??) ground electrode on cyl 2.

what cause issue on cyl 2?

attached photos about my plugs issue.
broken cyl2.jpg
cyl1 and cyl2.jpg
cyl2.jpg
cyl3.jpg
cyl4.jpg
cyl5.jpg
cyl6.jpg
 
Last edited:
Jul 27, 2017
150
#2
How do the logs look? i.e. Are fuel trims in check? Any timing pulls? How are AFRs on each bank?

Looks to me like you might have fuel distribution issues. Only going on what I've read from reading spark plugs.
Have a search on google for reading spark plugs.

From the little I have read 5 and 6 look like they may be running too hot. 2 may have been caused by detonation. I'm no expert so I'm sure other more knowledgeable folk can help more than I can.
 
Nov 10, 2017
37
#4
did you find the tip of the spark plug that broke ?
 

sch4400

New Member
Mar 20, 2018
9
#6
How do the logs look? i.e. Are fuel trims in check? Any timing pulls? How are AFRs on each bank?

Looks to me like you might have fuel distribution issues. Only going on what I've read from reading spark plugs.
Have a search on google for reading spark plugs.

From the little I have read 5 and 6 look like they may be running too hot. 2 may have been caused by detonation. I'm no expert so I'm sure other more knowledgeable folk can help more than I can.
Yeah I would be looking at your logs for sure.
attached log.

I had injector index # 12 all of cyl.
I had replaced old injector index #9 on bank 1 to see after got misfire on cyl 2
 

Attachments

Oct 3, 2018
18
#7
Is meth flowing properly?? Looks like it went way lean. Just a guess. Trims a look pretty high, but I'm no professional
 
Dec 1, 2016
193
New York
#8
looks to be running extremely lean/hot... that looks like tons of aluminum deposits on all of the plugs... drop a camera down into each cylinder and snap a pic of what the pistons look like. If fuel is flowing properly then tune is the next thing to look at (should've really been the first thing to look at).

When you are swapping these injectors, are you coding for the change? Rate of flow from each injector can be wildly different...

The logs show your AFR is pretty unstable and trims are maxing out on both banks. Not sure what timing you're tune is targeting but it also looks like you've got some significant corrections from 3-6* across multiple cylinders. HPFP pressure is dipping below 1500psi. Is you're port injection working at all?

Who is doing this "custom flash?" Fuel trims wouldn't be that far off if someone was actually tuning this car for you... This motor is going to be dead soon if not already.
 
Last edited:

sch4400

New Member
Mar 20, 2018
9
#9
looks to be running extremely lean/hot... that looks like tons of aluminum deposits on all of the plugs... drop a camera down into each cylinder and snap a pic of what the pistons look like. If fuel is flowing properly then tune is the next thing to look at (should've really been the first thing to look at).

When you are swapping these injectors, are you coding for the change? Rate of flow from each injector can be wildly different...

The logs show your AFR is pretty unstable and trims are maxing out on both banks. Not sure what timing you're running but it also looks like you've got some significant timing corrections from 3-6* across multiple cylinders. HPFP pressure is dipping below 1500psi. Is you're port injection working at all?

Who is doing this "custom flash?" Fuel trims wouldn't be that far off if someone was actually tuning this car for you... This motor is going to be dead soon if not already.
yes I did code all of injectors.
The MHD trebia(david) made me a flash map.

so..what should I do next???

I did drop a camera down into cylinder 1,2, and 3. There is looks like many of alumnimum depostis on top of the piston. but couldn't snap a pic.

I don't know well about the car.
how can I know the fuel is flowing properly???
also I have port injection but don't know it's working properly.
but there is value on meth on log. that meant it's wokring well?

some one told me it's from bad valve steam seal failed. is it true??

so..just worry about this situation and also don't know what to do.
 
Last edited:
Dec 1, 2016
193
New York
#10
yes I did code all of injectors.
The MHD trebia(david) made me a flash map.

so..what should I do next???
#1 thing to do is stop driving this car and take the logs to trebia... How new is this tune? Did it ever run right or are you still in the "tuning" phase?

I did drop a camera down into cylinder 1,2, and 3. There is looks like many of alumnimum depostis on top of the piston. but couldn't snap a pic.
You can buy an endoscope camera on Amazon with same day delivery for $15 with prime lol. They work well and oyu can record video or snap pics with them. Aluminum deposits are never a good sign. Post up pics of the carnage.

I don't know well about the car. how can I know the fuel is flowing properly??? also I have port injection but don't know it's working properly. but there is value on meth on log. that meant it's working well?
Meth is there for cooling, right? I would personally disconnect it until you get the tune dialed in. Then you know you're only relying on the direct injection and port injection for fueling.

Not sure on JB4 specifics. I haven't touched one in years but you wouldn't be the first person with a lean running Trebila tune and/or JB4 controlled PI not spraying :/

Some one told me it's from bad valve steam seal failed. is it true??
Who told you this? No, this is not bad valve stem seals unless you have serious valve damage on every cylinder and you've let compression destroy the valve seats over time (which would be the aluminum deposits). It's much more likely you have a lean condition causing detonation and you've melted some stuff. detonation explains the melted spark plugs and the shattered ceramic insulator tips on the plugs.

so..just worry about this situation and also don't know what to do.
Don't drive the car.

It absolutely amazes me you've thrown so much money at this car and it's tuned so poorly. We really need more history... like asked above, is this a fresh build that is JUST getting tuned? Or, have you been running the car for months on a "final" tune? Logs from previous revisions to show it used to run right?
 
Last edited:

sch4400

New Member
Mar 20, 2018
9
#11
#1 thing to do is stop driving this car and take the logs to trebia... How new is this tune? Did it ever run right or are you still in the "tuning" phase?



You can buy an endoscope camera on Amazon with same day delivery for $15 with prime lol. They work well and oyu can record video or snap pics with them. Aluminum deposits are never a good sign. Post up pics of the carnage.



Meth is there for cooling, right? I would personally disconnect it until you get the tune dialed in. Then you know you're only relying on the direct injection and port injection for fueling.

Not sure on JB4 specifics. I haven't touched one in years but you wouldn't be the first person with a lean running Trebia tune and/or JB4 controlled PI not spraying :/



Who told you this? Trebia? No, this is not bad valve stem seals unless you have serious valve damage on every cylinder and you've let compression destroy the valve seats over time (which would be the aluminum deposits). It's much more likely you have a lean condition causing detonation and you've melted some piston material. detonation explains the melted spark plugs and the shattered ceramic insulator tips on the plugs.




Don't drive the car.

It absolutely amazes me you've thrown so much money at this car and it's tuned so poorly. We really need more history... like asked above, is this a fresh build that is JUST getting tuned? Or, have you been running the car for months on a "final" tune?
I will drop the camera into cyl tomorrow at bmw service center.
and..will do compression test and leak down test also at bmw service center.

the meth is only for drop the temparature.
I will disconnect the meth pump .
actually have been running more than year.
The car was fine I think... cause it's not my daily car. I just drive sometime..so..actually, couldn't make sure it was good or not.
but suddenly happend like this.

I will attach photo about the cyl.
Thank you help me out..and..please advise me.
 
Dec 1, 2016
193
New York
#12
I will drop the camera into cyl tomorrow at bmw service center.
and..will do compression test and leak down test also at bmw service center.

the meth is only for drop the temparature.
I will disconnect the meth pump .
actually have been running more than year.
The car was fine I think... cause it's not my daily car. I just drive sometime..so..actually, couldn't make sure it was good or not.
but suddenly happend like this.

I will attach photo about the cyl.
Thank you help me out..and..please advise me.
Sounds like a hardware issue related to fuel delivery. LPFP pressure looks good. HPFP could be the issue, or the PI not spraying, or the direct injectors... The car isn't getting the right fuel. You have a lot of troubleshooting to do to find out what parts are bad. And, it looks to be too late already by the look of the aluminum deposits on the plugs.
 

sch4400

New Member
Mar 20, 2018
9
#13
Sounds like a hardware issue related to fuel delivery. LPFP pressure looks good. HPFP could be the issue, or the PI not spraying, or the direct injectors... The car isn't getting the right fuel. You have a lot of troubleshooting to do to find out what parts are bad. And, it looks to be too late already by the look of the aluminum deposits on the plugs.
Too late??
If I found and solve the problem..then shouldn't run high lever power???
 
Dec 1, 2016
193
New York
#14
Too late??
If I found and solve the problem..then shouldn't run high lever power???
I said that because you found melted aluminum in every cylinder. Can't fix melted aluminum. Hopefully it's just melted plug material. Hopefully that material didn't gouge up the cylinder walls. Best of luck... I would personally go back to a flash tune that should work 100% on STOCK fueling. Rule out the HPFP. Then add port injection back on or something. Maybe peopel with more experience with this many mods can chime in on how they would troubleshoot this.
 
Oct 3, 2018
18
#15
I'd try an OTS tune and go from there. Eliminate as many variables as possible, then gradually add supporting mods back in as they are confirmed to be working 100%. Stay in contact with your tuner and let him know what's going on
 
Jan 28, 2018
92
Strong Island
#16
what @Bnks334 said. You are running lean/hot and detonating. I can see the aluminum speckles on the plugs, which is coming off the piston and depositing on the electrodes...
 

sch4400

New Member
Mar 20, 2018
9
#17
I said that because you found melted aluminum in every cylinder. Can't fix melted aluminum. Hopefully it's just melted plug material. Hopefully that material didn't gouge up the cylinder walls. Best of luck... I would personally go back to a flash tune that should work 100% on STOCK fueling. Rule out the HPFP. Then add port injection back on or something. Maybe peopel with more experience with this many mods can chime in on how they would troubleshoot this.
I got a compression test by bmw service center.
cyl 1: 150 psi
cyl 2: 142 psi
cyl 3: 155 psi
cyl 4: 152 psi
cyl 5: 156 psi
cyl 6: 153 psi

fortunetly, cyl 2 is..little low.
cause...the broken plug is only cyl 2 .
I will take a picture about top of the piston.
the bmw center has camera..but..didn't work.

do you think...If I got best of luck(that material didn't gouge up the cylinder walls) then...can I re-tune to get high lever power with melted plug material on piston???
 
Jul 2, 2017
255
#19
How do the logs look? i.e. Are fuel trims in check? Any timing pulls? How are AFRs on each bank?

Looks to me like you might have fuel distribution issues. Only going on what I've read from reading spark plugs.
Have a search on google for reading spark plugs.

From the little I have read 5 and 6 look like they may be running too hot. 2 may have been caused by detonation. I'm no expert so I'm sure other more knowledgeable folk can help more than I can.
Agreed 2,5, and 6 are the worst ones. I also believe fuel /meth distribution issue. Logs do not look bad except for hpfp dip on top of 4th in the 1st log. I have not looked at the rest. afr , trims appear to be in check at a quick glance.
Also worth noting....your last Jb4 safety "2" is for lean AFR
 
Last edited:

sch4400

New Member
Mar 20, 2018
9
#20
I did walnut blasting on my car.
and I reaplced new plug and drove about 20 miles. normar driving and 2 times wot.
and put out the plug to see....
cyl 1,3,4,5,6 was same shape and color(white)...but.. only cyl 2 is black .
but...no misfire on cyl2. before wwalnut blasiting...I got a misfire on cyl2.
No smoke on exhaust, and no shake the car...no bump RPM...car is fine....
plugs.jpg
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads

Top