In search of getting MDrive, MDM, and the Power button functional

LMB335is

Corporal
Apr 12, 2017
227
FOB FL
I know @dyezak and myself have moved over to the IKM0S Rom at this point (with a huge thanks to @jyamona ). While I've gotten cruise control functional and the MDrive icon lights up in the cluster, the MDrive menu in the IDrive is still non functional with no way to access MDM and Darrick confirmed the same on his car. I did wire the Power button to pin 12 of the 1st connector in the DME (gray one as stated in M3 DME pinout, 1M DME doesn't show any connections for this lead) but it doesn't light up or make any difference that I can notice. Open to ideas from anyone really, especially @Bimaxtremeretro
 

aus335iguy

Lieutenant
Nov 18, 2017
856
I could change the items in the menu without any of the supporting mods. I had to exit out each time I changed one...Maybe post a video of what it looks like to you as a start?
 

LMB335is

Corporal
Apr 12, 2017
227
FOB FL
I could change the items in the menu without any of the supporting mods. I had to exit out each time I changed one...Maybe post a video of what it looks like to you as a start?
I can change them like you going back and forth but they don't stay. They all default back to "Unchanged" and whatever default setting it is in the sub menu...I think. I've tried to change them to specific settings and hold the M button to save the settings to Mdrive (correct?), turn on Mdrive and check the settings but nothing changed. I'll need to double check my M3 OM download to read up on MDM and MDrive to make sure I'm going about this correctly and it's not me effing it up. I'll get a short vid tomorrow to show what I have going on.
 
  • Like
Reactions: aus335iguy

aus335iguy

Lieutenant
Nov 18, 2017
856

I think the only ones in your car that *should work would be the DSC and the DCT but it could be that the DME isnt storing these OR theyre stored in another module somewhere. One other explanation would be that they’re protected by an FSC code.

If its not user error, maybe do another comparison between your car and the M3 trc files?
My money is on the DME.
 

L€X

New Member
Dec 30, 2018
8
Hello, guys! I swaped dct on my 335i n54. Then i swap m3 gws, szl, dsc, flash dct m3 gts soft. Mdm Mode turned on, but launch control and shift lights don't work. Maybe some one know what should do?
 

LMB335is

Corporal
Apr 12, 2017
227
FOB FL
Hello, guys! I swaped dct on my 335i n54. Then i swap m3 gws, szl, dsc, flash dct m3 gts soft. Mdm Mode turned on, but launch control and shift lights don't work. Maybe some one know what should do?
Do you have the DSC button, either the dash button or the M3 DSC console, button wired directly to the ABS/DSC? The dash DSC button will trigger the MDM indicator light in the cluster with factory wiring but will not actually enable MDM in the DSC or turn off DSC all the way off. The M3 DSC switch is wired directly to the DSC module, not routed through the JBBF like the 335i.

Has the ABS/DSC module been coded in properly as a M3 unit? Does the ECU tree in NCS Expert show it as MDSC and not DSC and has it been calibrated and the VIN written to the module?

Shift lights won't work. They use a signal from the M3 DME that our DMEs don't send.

Launch control should work for you. Are you following the procedure for a M3 and not a 335i? Remember traction control needs to be completely off with the M3 software, not just the one push of the DSC button like a 335i.
 
  • 2Like
Reactions: L€X and aus335iguy

L€X

New Member
Dec 30, 2018
8
Do you have the DSC button, either the dash button or the M3 DSC console, button wired directly to the ABS/DSC? The dash DSC button will trigger the MDM indicator light in the cluster with factory wiring but will not actually enable MDM in the DSC or turn off DSC all the way off. The M3 DSC switch is wired directly to the DSC module, not routed through the JBBF like the 335i.

Has the ABS/DSC module been coded in properly as a M3 unit? Does the ECU tree in NCS Expert show it as MDSC and not DSC and has it been calibrated and the VIN written to the module?

Shift lights won't work. They use a signal from the M3 DME that our DMEs don't send.

Launch control should work for you. Are you following the procedure for a M3 and not a 335i? Remember traction control needs to be completely off with the M3 software, not just the one push of the DSC button like a 335i.
Thank you for answer, yes, i have m3 dsc console with power button, edc and dsc off button, also mdm Mode turn on, but it doesn't work. Maybe problem with dsc, Will try code it as mdsc. And what about power button and mdm Mode? Maybe some one has solution for its work?
 
Top