BimmerGeeks Pro K+DCAN cable

Itsbrokeagain

Corporal
Jan 28, 2018
156
Strong Island
I don't think I got the warranty either, so I guess that means I'm out on the Bluetooth dongle as well? Its been handing for monitoring and I wanted to use it yesterday to monitor trans temps while I was filling up the trans fluid...
 

Torgus

Captain
Nov 6, 2016
1,099
Boston
I don't think I got the warranty either, so I guess that means I'm out on the Bluetooth dongle as well? Its been handing for monitoring and I wanted to use it yesterday to monitor trans temps while I was filling up the trans fluid...
If you find an email address please post it. I guess I will ask them to send me a new cable even though I bought a new one from another vendor already. My fear is with a flakey cable looses connection in the middle of a flash and it Fs up the DME. Not worth the hassle or risk imo.

Why would a bluetooth adapter go bad? Bad solder jobs or a failed component should be VERY rare now a days unless you buy the cheapest of the cheap from China.
 

Itsbrokeagain

Corporal
Jan 28, 2018
156
Strong Island
If you find an email address please post it. I guess I will ask them to send me a new cable even though I bought a new one from another vendor already. My fear is with a flakey cable looses connection in the middle of a flash and it Fs up the DME. Not worth the hassle or risk imo.

Why would a bluetooth adapter go bad? Bad solder jobs or a failed component should be VERY rare now a days unless you buy the cheapest of the cheap from China.
No idea. I would notice the LED in it light up red for a second like the cable when you initially plug it in, and then it would connect. Used it several times while driving. Updated the software and used it in my E46 once for shits and giggles. Right after that I started getting 'unknown vehicle' errors or it straight up wouldn't see it. And the led in it would no longer light up. Maybe I can try clearing cache or something on my phone or tablet?
 
  • Informative
Reactions: Torgus

Torgus

Captain
Nov 6, 2016
1,099
Boston
Also @Torgus , what kinda adaptor did you buy, hunting around on Amazon right now
No problem: https://www.amazon.com/gp/product/B07CKRCY1K/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1

I have had good luck with that brand before. Please note I have no tried them out yet to flash but I have no reason to believe they will not work flawlessly, it is just a cable at the end of the day and as long as they go by the USB spec everything should be fine.

It sounds like you are in a rush but if you can wait to this evening I will go and make sure I can connect to the OBD2 port in my E92. Will just take a moment once I get home. The cables are small money luckily.


Maybe I can try clearing cache or something on my phone or tablet?
It is worth a shot but I doubt it will help. You would think they would warn you of that well ahead of time to save everyone the head ache.
 
  • Like
Reactions: Itsbrokeagain

Torgus

Captain
Nov 6, 2016
1,099
Boston
Last edited:
  • Like
Reactions: Itsbrokeagain

Dean Giroir

New Member
Jun 21, 2019
1
Atlanta
Did it work? So you guys are having trouble flashing because of faulty otg dongles? my E93 will not complete mdh flash. 3 K+DCAN cables one from bimmer geeks (garbage). 2 high amp battery charges from autozone. 2 cars straight wired instead of charges, running. just picked my 3rd android device waiting for it to charge. But the dongle? im using the same one from the geeks. ive been making those for years.

 
Top